summaryrefslogtreecommitdiffstats
path: root/third_party/rust/jsparagus/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/jsparagus/Cargo.toml')
-rw-r--r--third_party/rust/jsparagus/Cargo.toml69
1 files changed, 69 insertions, 0 deletions
diff --git a/third_party/rust/jsparagus/Cargo.toml b/third_party/rust/jsparagus/Cargo.toml
new file mode 100644
index 0000000000..54ef2890c3
--- /dev/null
+++ b/third_party/rust/jsparagus/Cargo.toml
@@ -0,0 +1,69 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "jsparagus"
+version = "0.1.0"
+authors = ["The jsparagus Project Developers"]
+publish = false
+description = "A JavaScript parser"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/mozilla-spidermonkey/jsparagus"
+
+[profile.release]
+debug = true
+
+[lib]
+
+[[bin]]
+name = "smoosh_tools"
+path = "src/bin/smoosh_tools.rs"
+
+[dependencies.jsparagus-ast]
+path = "crates/ast"
+
+[dependencies.jsparagus-driver]
+path = "crates/driver"
+optional = true
+
+[dependencies.jsparagus-emitter]
+path = "crates/emitter"
+
+[dependencies.jsparagus-generated-parser]
+path = "crates/generated_parser"
+
+[dependencies.jsparagus-interpreter]
+path = "crates/interpreter"
+optional = true
+
+[dependencies.jsparagus-json-log]
+path = "crates/json-log"
+
+[dependencies.jsparagus-parser]
+path = "crates/parser"
+
+[dependencies.jsparagus-scope]
+path = "crates/scope"
+
+[dependencies.jsparagus-stencil]
+path = "crates/stencil"
+
+[features]
+default = []
+full = [
+ "jsparagus-driver",
+ "jsparagus-interpreter",
+]
+logging = ["jsparagus-parser/logging"]
+
+[workspace]