summaryrefslogtreecommitdiffstats
path: root/third_party/rust/linked-hash-map/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/linked-hash-map/Cargo.toml')
-rw-r--r--third_party/rust/linked-hash-map/Cargo.toml45
1 files changed, 45 insertions, 0 deletions
diff --git a/third_party/rust/linked-hash-map/Cargo.toml b/third_party/rust/linked-hash-map/Cargo.toml
new file mode 100644
index 0000000000..51deccd1c4
--- /dev/null
+++ b/third_party/rust/linked-hash-map/Cargo.toml
@@ -0,0 +1,45 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "linked-hash-map"
+version = "0.5.6"
+authors = [
+ "Stepan Koltsov <stepan.koltsov@gmail.com>",
+ "Andrew Paseltiner <apaseltiner@gmail.com>",
+]
+exclude = [
+ ".github",
+ "src/tests",
+]
+description = "A HashMap wrapper that holds key-value pairs in insertion order"
+homepage = "https://github.com/contain-rs/linked-hash-map"
+documentation = "https://docs.rs/linked-hash-map"
+readme = "README.md"
+keywords = ["data-structures"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/contain-rs/linked-hash-map"
+
+[dependencies.heapsize]
+version = "0.4"
+optional = true
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+
+[dev-dependencies.serde_test]
+version = "1.0"
+
+[features]
+heapsize_impl = ["heapsize"]
+nightly = []
+serde_impl = ["serde"]