summaryrefslogtreecommitdiffstats
path: root/third_party/rust/lmdb-rkv-sys/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/lmdb-rkv-sys/Cargo.toml')
-rw-r--r--third_party/rust/lmdb-rkv-sys/Cargo.toml59
1 files changed, 59 insertions, 0 deletions
diff --git a/third_party/rust/lmdb-rkv-sys/Cargo.toml b/third_party/rust/lmdb-rkv-sys/Cargo.toml
new file mode 100644
index 0000000000..e8f59d983f
--- /dev/null
+++ b/third_party/rust/lmdb-rkv-sys/Cargo.toml
@@ -0,0 +1,59 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "lmdb-rkv-sys"
+version = "0.11.2"
+authors = ["Dan Burkert <dan@danburkert.com>", "Victor Porof <vporof@mozilla.com>"]
+build = "build.rs"
+description = "Rust bindings for liblmdb."
+homepage = "https://github.com/mozilla/lmdb-rs"
+documentation = "https://docs.rs/lmdb-rkv-sys"
+readme = "../README.md"
+keywords = ["LMDB", "database", "storage-engine", "bindings", "library"]
+categories = ["database", "external-ffi-bindings"]
+license = "Apache-2.0"
+repository = "https://github.com/mozilla/lmdb-rs.git"
+
+[lib]
+name = "lmdb_sys"
+[dependencies.libc]
+version = "0.2"
+[build-dependencies.bindgen]
+version = "0.53.2"
+features = ["runtime"]
+optional = true
+default-features = false
+
+[build-dependencies.cc]
+version = "1.0"
+
+[build-dependencies.pkg-config]
+version = "0.3"
+
+[features]
+default = []
+mdb_idl_logn_10 = []
+mdb_idl_logn_11 = []
+mdb_idl_logn_12 = []
+mdb_idl_logn_13 = []
+mdb_idl_logn_14 = []
+mdb_idl_logn_15 = []
+mdb_idl_logn_8 = []
+mdb_idl_logn_9 = []
+with-asan = []
+with-fuzzer = []
+with-fuzzer-no-link = []
+[badges.appveyor]
+repository = "mozilla/lmdb-rs"
+
+[badges.travis-ci]
+repository = "mozilla/lmdb-rs"