summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-transport/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/neqo-transport/Cargo.toml')
-rw-r--r--third_party/rust/neqo-transport/Cargo.toml45
1 files changed, 45 insertions, 0 deletions
diff --git a/third_party/rust/neqo-transport/Cargo.toml b/third_party/rust/neqo-transport/Cargo.toml
new file mode 100644
index 0000000000..6d9f5173a5
--- /dev/null
+++ b/third_party/rust/neqo-transport/Cargo.toml
@@ -0,0 +1,45 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.57.0"
+name = "neqo-transport"
+version = "0.6.4"
+authors = [
+ "EKR <ekr@rtfm.com>",
+ "Andy Grover <agrover@mozilla.com>",
+]
+license = "MIT/Apache-2.0"
+
+[dependencies]
+indexmap = "1.0"
+lazy_static = "1.3.0"
+qlog = "0.4.0"
+smallvec = "1.0.0"
+
+[dependencies.log]
+version = "0.4.0"
+default-features = false
+
+[dependencies.neqo-common]
+path = "../neqo-common"
+
+[dependencies.neqo-crypto]
+path = "../neqo-crypto"
+
+[dev-dependencies.test-fixture]
+path = "../test-fixture"
+
+[features]
+default = ["deny-warnings"]
+deny-warnings = []
+fuzzing = ["neqo-crypto/fuzzing"]