summaryrefslogtreecommitdiffstats
path: root/third_party/rust/tabs/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/tabs/Cargo.toml')
-rw-r--r--third_party/rust/tabs/Cargo.toml77
1 files changed, 77 insertions, 0 deletions
diff --git a/third_party/rust/tabs/Cargo.toml b/third_party/rust/tabs/Cargo.toml
new file mode 100644
index 0000000000..99d52bd278
--- /dev/null
+++ b/third_party/rust/tabs/Cargo.toml
@@ -0,0 +1,77 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "tabs"
+version = "0.1.0"
+authors = ["application-services@mozilla.com"]
+exclude = [
+ "/android",
+ "/ios",
+]
+readme = "README.md"
+license = "MPL-2.0"
+
+[dependencies]
+anyhow = "1.0"
+lazy_static = "1.4"
+log = "0.4"
+serde = "1"
+serde_derive = "1"
+serde_json = "1"
+thiserror = "1.0"
+uniffi = "0.23"
+url = "2.1"
+
+[dependencies.error-support]
+path = "../support/error"
+
+[dependencies.interrupt-support]
+path = "../support/interrupt"
+
+[dependencies.rusqlite]
+version = "0.28.0"
+features = [
+ "bundled",
+ "unlock_notify",
+]
+
+[dependencies.sql-support]
+path = "../support/sql"
+
+[dependencies.sync-guid]
+path = "../support/guid"
+features = ["random"]
+
+[dependencies.sync15]
+path = "../sync15"
+features = ["sync-engine"]
+
+[dev-dependencies]
+tempfile = "3.1"
+
+[dev-dependencies.env_logger]
+version = "0.8.0"
+features = [
+ "termcolor",
+ "atty",
+ "humantime",
+]
+default-features = false
+
+[build-dependencies.uniffi]
+version = "0.23"
+features = ["build"]
+
+[features]
+default = []
+full-sync = ["sync15/standalone-sync"]