summaryrefslogtreecommitdiffstats
path: root/gfx/wr/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /gfx/wr/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--gfx/wr/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/gfx/wr/Cargo.toml b/gfx/wr/Cargo.toml
new file mode 100644
index 0000000000..59962d197c
--- /dev/null
+++ b/gfx/wr/Cargo.toml
@@ -0,0 +1,27 @@
+[workspace]
+members = [
+ "examples",
+ "webrender",
+ "webrender_api",
+ "wrench",
+ "example-compositor/compositor",
+]
+
+[profile.release]
+debug = true
+panic = "abort"
+
+[profile.dev]
+panic = "abort"
+
+# optimizing glsl more makes a big difference in swgl build times
+[profile.dev.package.glsl]
+opt-level = 2
+
+[profile.release.package.glsl]
+opt-level = 2
+
+[patch.crates-io]
+fog = { path = "fog" }
+# use a patched version of glutin that works on android
+glutin = { version = "0.28", git = "https://github.com/jamienicol/glutin", branch="wr" }