summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/compat/webkit-linear-gradient-line-top.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /testing/web-platform/tests/compat/webkit-linear-gradient-line-top.html
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/compat/webkit-linear-gradient-line-top.html')
-rw-r--r--testing/web-platform/tests/compat/webkit-linear-gradient-line-top.html23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/web-platform/tests/compat/webkit-linear-gradient-line-top.html b/testing/web-platform/tests/compat/webkit-linear-gradient-line-top.html
new file mode 100644
index 0000000000..2df36ef3cd
--- /dev/null
+++ b/testing/web-platform/tests/compat/webkit-linear-gradient-line-top.html
@@ -0,0 +1,23 @@
+<!doctype html>
+<title>-webkit-linear-gradient(top)</title>
+<link rel="author" title="Xidorn Quan" href="me@upsuper.org">
+<link rel="author" title="Mozilla" href="https://www.mozilla.org">
+<link rel="help" href="https://compat.spec.whatwg.org/#css-gradients-webkit-linear-gradient">
+<meta name="assert" content="'top' in -webkit-linear-gradient is equivalent to 'to bottom' in modern syntax">
+<link rel="match" href="green-ref.html">
+<meta name="fuzzy" content="maxDifference=0-1; totalPixels=0-4000">
+<style>
+ #outer {
+ width: 100px;
+ height: 100px;
+ overflow: hidden;
+ }
+ #inner {
+ width: 100px;
+ height: 200px;
+ background-image: -webkit-linear-gradient(top, green 50%, red 50%);
+ }
+</style>
+<div id="outer">
+ <div id="inner"></div>
+</div>