summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/dom/events/event-global-is-still-set-when-coercing-beforeunload-result.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /testing/web-platform/tests/dom/events/event-global-is-still-set-when-coercing-beforeunload-result.html
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/dom/events/event-global-is-still-set-when-coercing-beforeunload-result.html')
-rw-r--r--testing/web-platform/tests/dom/events/event-global-is-still-set-when-coercing-beforeunload-result.html23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/web-platform/tests/dom/events/event-global-is-still-set-when-coercing-beforeunload-result.html b/testing/web-platform/tests/dom/events/event-global-is-still-set-when-coercing-beforeunload-result.html
new file mode 100644
index 0000000000..a64c8b6b8b
--- /dev/null
+++ b/testing/web-platform/tests/dom/events/event-global-is-still-set-when-coercing-beforeunload-result.html
@@ -0,0 +1,23 @@
+<!doctype html>
+<meta charset="utf-8">
+<title>window.event is still set when 'beforeunload' result is coerced to string</title>
+<link rel="help" href="https://dom.spec.whatwg.org/#ref-for-window-current-event%E2%91%A1">
+<link rel="help" href="https://webidl.spec.whatwg.org/#call-a-user-objects-operation">
+
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+
+<iframe id="iframe" src="resources/event-global-is-still-set-when-coercing-beforeunload-result-frame.html"></iframe>
+<body>
+<script>
+window.onload = () => {
+ async_test(t => {
+ iframe.onload = t.step_func_done(() => {
+ assert_equals(typeof window.currentEventInToString, "object");
+ assert_equals(window.currentEventInToString.type, "beforeunload");
+ });
+
+ iframe.contentWindow.location.href = "about:blank";
+ });
+};
+</script>