summaryrefslogtreecommitdiffstats
path: root/third_party/rust/bhttp/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/bhttp/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/bhttp/Cargo.toml')
-rw-r--r--third_party/rust/bhttp/Cargo.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/third_party/rust/bhttp/Cargo.toml b/third_party/rust/bhttp/Cargo.toml
new file mode 100644
index 0000000000..d7ae9a182f
--- /dev/null
+++ b/third_party/rust/bhttp/Cargo.toml
@@ -0,0 +1,41 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "bhttp"
+version = "0.2.3"
+authors = ["Martin Thomson <mt@lowentropy.net>"]
+description = "Binary HTTP messages (draft-ietf-httpbis-binary-message)"
+readme = "README.md"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/martinthomson/ohttp"
+
+[dependencies.url]
+version = "2"
+
+[dev-dependencies.hex]
+version = "0.4"
+
+[features]
+bhttp = [
+ "read-bhttp",
+ "write-bhttp",
+]
+default = ["bhttp"]
+http = [
+ "read-http",
+ "write-http",
+]
+read-bhttp = []
+read-http = []
+write-bhttp = []
+write-http = []