summaryrefslogtreecommitdiffstats
path: root/third_party/rust/glean-core/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/glean-core/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/glean-core/Cargo.toml')
-rw-r--r--third_party/rust/glean-core/Cargo.toml143
1 files changed, 143 insertions, 0 deletions
diff --git a/third_party/rust/glean-core/Cargo.toml b/third_party/rust/glean-core/Cargo.toml
new file mode 100644
index 0000000000..bca564a929
--- /dev/null
+++ b/third_party/rust/glean-core/Cargo.toml
@@ -0,0 +1,143 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "glean-core"
+version = "51.8.2"
+authors = [
+ "Jan-Erik Rediger <jrediger@mozilla.com>",
+ "The Glean Team <glean-team@mozilla.com>",
+]
+include = [
+ "/README.md",
+ "/LICENSE",
+ "/src",
+ "/examples",
+ "/tests",
+ "/Cargo.toml",
+ "/uniffi.toml",
+ "/build.rs",
+]
+description = "A modern Telemetry library"
+readme = "README.md"
+keywords = ["telemetry"]
+license = "MPL-2.0"
+repository = "https://github.com/mozilla/glean"
+
+[package.metadata.glean]
+glean-parser = "6.3.0"
+
+[dependencies.bincode]
+version = "1.2.1"
+
+[dependencies.chrono]
+version = "0.4.10"
+features = ["serde"]
+
+[dependencies.crossbeam-channel]
+version = "0.5"
+
+[dependencies.flate2]
+version = "1.0.19"
+
+[dependencies.log]
+version = "0.4.8"
+
+[dependencies.once_cell]
+version = "1.4.1"
+
+[dependencies.remove_dir_all]
+version = "0.5.3"
+
+[dependencies.rkv]
+version = "0.18.2"
+features = ["lmdb"]
+default-features = false
+
+[dependencies.serde]
+version = "1.0.104"
+features = ["derive"]
+
+[dependencies.serde_json]
+version = "1.0.44"
+
+[dependencies.thiserror]
+version = "1.0.4"
+
+[dependencies.time]
+version = "0.1.40"
+
+[dependencies.uniffi]
+version = "0.21.0"
+
+[dependencies.uniffi_macros]
+version = "0.21.0"
+
+[dependencies.uuid]
+version = "1.0"
+features = ["v4"]
+
+[dependencies.whatsys]
+version = "0.1.2"
+
+[dependencies.zeitstempel]
+version = "0.1.0"
+
+[dev-dependencies.ctor]
+version = "0.1.12"
+
+[dev-dependencies.env_logger]
+version = "0.9.0"
+features = [
+ "termcolor",
+ "atty",
+ "humantime",
+]
+default-features = false
+
+[dev-dependencies.iso8601]
+version = "0.4"
+
+[dev-dependencies.tempfile]
+version = "3.1.0"
+
+[build-dependencies.uniffi_build]
+version = "0.21.0"
+features = ["builtin-bindgen"]
+
+[features]
+preinit_million_queue = []
+
+[target."cfg(not(target_os = \"android\"))".dependencies.env_logger]
+version = "0.9.0"
+features = [
+ "termcolor",
+ "atty",
+ "humantime",
+]
+default-features = false
+
+[target."cfg(target_os = \"android\")".dependencies.android_logger]
+version = "0.11.0"
+default-features = false
+
+[target."cfg(target_os = \"ios\")".dependencies.oslog]
+version = "0.1.0"
+features = ["logger"]
+default-features = false
+
+[badges.circle-ci]
+branch = "main"
+repository = "mozilla/glean"
+
+[badges.maintenance]
+status = "actively-developed"