summaryrefslogtreecommitdiffstats
path: root/third_party/rust/idna/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/idna/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--third_party/rust/idna/Cargo.toml54
1 files changed, 54 insertions, 0 deletions
diff --git a/third_party/rust/idna/Cargo.toml b/third_party/rust/idna/Cargo.toml
new file mode 100644
index 0000000000..138a27162a
--- /dev/null
+++ b/third_party/rust/idna/Cargo.toml
@@ -0,0 +1,54 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "idna"
+version = "0.2.3"
+authors = ["The rust-url developers"]
+autotests = false
+description = "IDNA (Internationalizing Domain Names in Applications) and Punycode."
+license = "MIT/Apache-2.0"
+repository = "https://github.com/servo/rust-url/"
+
+[lib]
+doctest = false
+
+[[test]]
+name = "tests"
+harness = false
+
+[[test]]
+name = "unit"
+
+[[bench]]
+name = "all"
+harness = false
+[dependencies.matches]
+version = "0.1"
+
+[dependencies.unicode-bidi]
+version = "0.3"
+
+[dependencies.unicode-normalization]
+version = "0.1.17"
+[dev-dependencies.assert_matches]
+version = "1.3"
+
+[dev-dependencies.bencher]
+version = "0.1"
+
+[dev-dependencies.rustc-test]
+version = "0.3"
+
+[dev-dependencies.serde_json]
+version = "1.0"