summaryrefslogtreecommitdiffstats
path: root/third_party/rust/mio-named-pipes/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/mio-named-pipes/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/mio-named-pipes/Cargo.toml')
-rw-r--r--third_party/rust/mio-named-pipes/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/third_party/rust/mio-named-pipes/Cargo.toml b/third_party/rust/mio-named-pipes/Cargo.toml
new file mode 100644
index 0000000000..ab9410c523
--- /dev/null
+++ b/third_party/rust/mio-named-pipes/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "mio-named-pipes"
+version = "0.1.6"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+license = "MIT/Apache-2.0"
+readme = "README.md"
+repository = "https://github.com/alexcrichton/mio-named-pipes"
+homepage = "https://github.com/alexcrichton/mio-named-pipes"
+documentation = "https://docs.rs/mio-named-pipes/0.1/x86_64-pc-windows-msvc/mio_named_pipes/"
+description = """
+Windows named pipe bindings for mio.
+"""
+
+[target.'cfg(windows)'.dependencies]
+log = "0.4"
+mio = "0.6.5"
+miow = "0.3"
+
+[target.'cfg(windows)'.dependencies.winapi]
+version = "0.3"
+features = ["winerror", "ioapiset", "minwinbase", "winbase"]
+
+[dev-dependencies]
+env_logger = { version = "0.4", default-features = false }
+rand = "0.4"