summaryrefslogtreecommitdiffstats
path: root/third_party/rust/rure/examples/compile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/rure/examples/compile
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/rure/examples/compile')
-rwxr-xr-xthird_party/rust/rure/examples/compile9
1 files changed, 9 insertions, 0 deletions
diff --git a/third_party/rust/rure/examples/compile b/third_party/rust/rure/examples/compile
new file mode 100755
index 0000000000..a7566b791d
--- /dev/null
+++ b/third_party/rust/rure/examples/compile
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+set -ex
+
+# N.B. Add `--release` flag to `cargo build` to make the example run faster.
+cargo build --manifest-path ../Cargo.toml
+gcc -O3 -DDEBUG -o iter iter.c -ansi -Wall -I../include -L../../target/debug -lrure
+# If you're using librure.a, then you'll need to link other stuff:
+# -lutil -ldl -lpthread -lgcc_s -lc -lm -lrt -lutil -lrure