summaryrefslogtreecommitdiffstats
path: root/third_party/rust/viaduct/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/viaduct/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/viaduct/Cargo.toml')
-rw-r--r--third_party/rust/viaduct/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/third_party/rust/viaduct/Cargo.toml b/third_party/rust/viaduct/Cargo.toml
new file mode 100644
index 0000000000..838144960e
--- /dev/null
+++ b/third_party/rust/viaduct/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "viaduct"
+version = "0.1.0"
+authors = ["Thom Chiovoloni <tchiovoloni@mozilla.com>"]
+edition = "2021"
+license = "MPL-2.0"
+exclude = ["/android", "/ios"]
+
+[lib]
+crate-type = ["lib"]
+
+[dependencies]
+url = "2.1" # mozilla-central can't yet take 2.2 (see bug 1734538)
+log = "0.4"
+serde = "1"
+serde_json = "1"
+once_cell = "1.5"
+parking_lot = { version = ">=0.11,<=0.12" }
+prost = "0.8"
+prost-derive = "0.8"
+ffi-support = "0.4"
+thiserror = "1.0"