summaryrefslogtreecommitdiffstats
path: root/toolkit/components/xulstore/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /toolkit/components/xulstore/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/components/xulstore/Cargo.toml')
-rw-r--r--toolkit/components/xulstore/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/toolkit/components/xulstore/Cargo.toml b/toolkit/components/xulstore/Cargo.toml
new file mode 100644
index 0000000000..307020f33c
--- /dev/null
+++ b/toolkit/components/xulstore/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "xulstore"
+version = "0.1.0"
+authors = ["The Mozilla Project Developers"]
+license = "MPL-2.0"
+
+[dependencies]
+crossbeam-utils = "0.8"
+cstr = "0.2"
+libc = "0.2"
+log = "0.4"
+moz_task = { path = "../../../xpcom/rust/moz_task" }
+nsstring = { path = "../../../xpcom/rust/nsstring" }
+nserror = { path = "../../../xpcom/rust/nserror" }
+once_cell = "1"
+rkv = { version = "0.18", default-features = false, features=["no-canonicalize-path"] }
+serde_json = "1"
+tempfile = "3"
+thiserror = "1"
+xpcom = { path = "../../../xpcom/rust/xpcom" }