summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/compat/webkit-gradient-comma.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/compat/webkit-gradient-comma.html')
-rw-r--r--testing/web-platform/tests/compat/webkit-gradient-comma.html15
1 files changed, 15 insertions, 0 deletions
diff --git a/testing/web-platform/tests/compat/webkit-gradient-comma.html b/testing/web-platform/tests/compat/webkit-gradient-comma.html
new file mode 100644
index 0000000000..b288a9a43f
--- /dev/null
+++ b/testing/web-platform/tests/compat/webkit-gradient-comma.html
@@ -0,0 +1,15 @@
+<!DOCTYPE html>
+<link rel="help" href="https://compat.spec.whatwg.org/#css-gradients-webkit-radial-gradient">
+<link rel="help" href="https://www.w3.org/TR/css3-images/#radial-gradients">
+<meta name="assert" content="Negative radii values are invalid.">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script>
+test(function() {
+ assert_true(CSS.supports("background-image", "-webkit-radial-gradient(1px 2px, 3% 4%, red, blue)"));
+}, '-webkit-radial-gradient accepts comma before color stops.');
+
+test(function() {
+ assert_false(CSS.supports("background-image", "-webkit-radial-gradient(1px 2px, 3% 4% red, blue)"));
+}, '-webkit-radial-gradient rejects missing comma before color stops.');
+</script>