summaryrefslogtreecommitdiffstats
path: root/third_party/python/idna-ssl/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/python/idna-ssl/setup.py')
-rw-r--r--third_party/python/idna-ssl/setup.py53
1 files changed, 53 insertions, 0 deletions
diff --git a/third_party/python/idna-ssl/setup.py b/third_party/python/idna-ssl/setup.py
new file mode 100644
index 0000000000..da180db2c5
--- /dev/null
+++ b/third_party/python/idna-ssl/setup.py
@@ -0,0 +1,53 @@
+import io
+import os
+import re
+import sys
+
+from setuptools import setup
+
+needs_pytest = 'pytest' in set(sys.argv)
+
+
+def get_version():
+ regex = r"__version__\s=\s\'(?P<version>[\d\.ab]+?)\'"
+
+ path = ('idna_ssl.py',)
+
+ return re.search(regex, read(*path)).group('version')
+
+
+def read(*parts):
+ filename = os.path.join(os.path.abspath(os.path.dirname(__file__)), *parts)
+
+ with io.open(filename, encoding='utf-8', mode='rt') as fp:
+ return fp.read()
+
+
+setup(
+ name='idna-ssl',
+ version=get_version(),
+ author='Victor Kovtun',
+ author_email='hellysmile@gmail.com',
+ url='https://github.com/aio-libs/idna-ssl',
+ description='Patch ssl.match_hostname for Unicode(idna) domains support',
+ long_description=read('README.rst'),
+ setup_requires=['pytest-runner'] if needs_pytest else [],
+ tests_require=['pytest', 'pytest-asyncio', 'pytest-cov', 'aiohttp>2.3'],
+ py_modules=['idna_ssl'],
+ install_requires=['idna>=2.0'],
+ include_package_data=True,
+ zip_safe=False,
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ ],
+ keywords=['ssl', 'Unicode', 'idna', 'match_hostname'],
+)