summaryrefslogtreecommitdiffstats
path: root/third_party/rust/audioipc2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/audioipc2/Cargo.toml')
-rw-r--r--third_party/rust/audioipc2/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/third_party/rust/audioipc2/Cargo.toml b/third_party/rust/audioipc2/Cargo.toml
new file mode 100644
index 0000000000..17ef5b94e8
--- /dev/null
+++ b/third_party/rust/audioipc2/Cargo.toml
@@ -0,0 +1,55 @@
+[package]
+name = "audioipc2"
+version = "0.5.0"
+authors = [
+ "Matthew Gregan <kinetik@flim.org>",
+ "Dan Glastonbury <dan.glastonbury@gmail.com>"
+ ]
+license = "ISC"
+description = "Remote Cubeb IPC"
+edition = "2018"
+
+[dependencies]
+bincode = "1.3"
+byteorder = "1"
+bytes = "1"
+cubeb = "0.10"
+log = "0.4"
+serde = "1"
+serde_derive = "1"
+serde_bytes = "0.11"
+mio = { version = "0.8", features = ["os-poll", "net", "os-ext"] }
+slab = "0.4"
+scopeguard = "1.1.0"
+crossbeam-channel = "0.5"
+
+[target.'cfg(unix)'.dependencies]
+iovec = "0.1"
+libc = "0.2"
+memmap2 = "0.5"
+arrayvec = "0.7"
+
+[target.'cfg(target_os = "linux")'.dependencies.audio_thread_priority]
+version = "0.26.1"
+default-features = false
+
+[target.'cfg(windows)'.dependencies]
+winapi = { version = "0.3", features = ["combaseapi", "handleapi", "memoryapi", "objbase"] }
+
+[target.'cfg(target_os = "android")'.dependencies]
+ashmem = "0.1.2"
+
+[dependencies.error-chain]
+version = "0.12.0"
+default-features = false
+
+[build-dependencies]
+cc = "1.0"
+
+[dev-dependencies]
+env_logger = "0.9"
+criterion = { version = "0.3", features = ["html_reports"] }
+
+[[bench]]
+name = "serialization"
+harness = false