summaryrefslogtreecommitdiffstats
path: root/third_party/rust/bytes-0.4.12/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/bytes-0.4.12/Cargo.toml')
-rw-r--r--third_party/rust/bytes-0.4.12/Cargo.toml46
1 files changed, 46 insertions, 0 deletions
diff --git a/third_party/rust/bytes-0.4.12/Cargo.toml b/third_party/rust/bytes-0.4.12/Cargo.toml
new file mode 100644
index 0000000000..96137c1519
--- /dev/null
+++ b/third_party/rust/bytes-0.4.12/Cargo.toml
@@ -0,0 +1,46 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "bytes"
+version = "0.4.12"
+authors = ["Carl Lerche <me@carllerche.com>"]
+exclude = [".gitignore", ".travis.yml", "deploy.sh", "bench/**/*", "test/**/*"]
+description = "Types and traits for working with bytes"
+homepage = "https://github.com/carllerche/bytes"
+documentation = "https://docs.rs/bytes/0.4.12/bytes"
+readme = "README.md"
+keywords = ["buffers", "zero-copy", "io"]
+categories = ["network-programming", "data-structures"]
+license = "MIT"
+repository = "https://github.com/carllerche/bytes"
+[package.metadata.docs.rs]
+features = ["i128"]
+[dependencies.byteorder]
+version = "1.1.0"
+
+[dependencies.either]
+version = "1.5"
+optional = true
+default-features = false
+
+[dependencies.iovec]
+version = "0.1"
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+[dev-dependencies.serde_test]
+version = "1.0"
+
+[features]
+i128 = ["byteorder/i128"]