summaryrefslogtreecommitdiffstats
path: root/third_party/rust/comedy/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/comedy/Cargo.toml')
-rw-r--r--third_party/rust/comedy/Cargo.toml29
1 files changed, 29 insertions, 0 deletions
diff --git a/third_party/rust/comedy/Cargo.toml b/third_party/rust/comedy/Cargo.toml
new file mode 100644
index 0000000000..c94079b84e
--- /dev/null
+++ b/third_party/rust/comedy/Cargo.toml
@@ -0,0 +1,29 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "comedy"
+version = "0.2.0"
+authors = ["Adam Gashlin <agashlin@mozilla.com>"]
+description = "Windows error handling, COM, and handles"
+keywords = ["windows", "com", "win32"]
+categories = ["api-bindings", "os::windows-apis"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/agashlin/comedy-rs"
+[package.metadata.docs.rs]
+default-target = "x86_64-pc-windows-msvc"
+[dependencies.winapi]
+version = "0.3.6"
+features = ["basetsd", "combaseapi", "errhandlingapi", "handleapi", "impl-default", "minwindef", "objbase", "unknwnbase", "winbase", "winerror", "wtypes", "wtypesbase"]
+[dev-dependencies.winapi]
+version = "0.3.6"
+features = ["bits", "fileapi", "guiddef"]