summaryrefslogtreecommitdiffstats
path: root/third_party/rust/crossbeam-epoch-0.8.2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/crossbeam-epoch-0.8.2/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/third_party/rust/crossbeam-epoch-0.8.2/Cargo.toml b/third_party/rust/crossbeam-epoch-0.8.2/Cargo.toml
new file mode 100644
index 0000000000..7d5c0943b9
--- /dev/null
+++ b/third_party/rust/crossbeam-epoch-0.8.2/Cargo.toml
@@ -0,0 +1,55 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "crossbeam-epoch"
+version = "0.8.2"
+authors = ["The Crossbeam Project Developers"]
+description = "Epoch-based garbage collection"
+homepage = "https://github.com/crossbeam-rs/crossbeam/tree/master/crossbeam-epoch"
+documentation = "https://docs.rs/crossbeam-epoch"
+readme = "README.md"
+keywords = ["lock-free", "rcu", "atomic", "garbage"]
+categories = ["concurrency", "memory-management", "no-std"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/crossbeam-rs/crossbeam"
+[dependencies.cfg-if]
+version = "0.1.2"
+
+[dependencies.crossbeam-utils]
+version = "0.7"
+default-features = false
+
+[dependencies.lazy_static]
+version = "1"
+optional = true
+
+[dependencies.maybe-uninit]
+version = "2.0.0"
+
+[dependencies.memoffset]
+version = "0.5"
+
+[dependencies.scopeguard]
+version = "1"
+default-features = false
+[dev-dependencies.rand]
+version = "0.6"
+[build-dependencies.autocfg]
+version = "1"
+
+[features]
+alloc = ["crossbeam-utils/alloc"]
+default = ["std"]
+nightly = ["crossbeam-utils/nightly"]
+sanitize = []
+std = ["crossbeam-utils/std", "lazy_static"]