summaryrefslogtreecommitdiffstats
path: root/third_party/rust/flagset/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/flagset/Cargo.toml')
-rw-r--r--third_party/rust/flagset/Cargo.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/third_party/rust/flagset/Cargo.toml b/third_party/rust/flagset/Cargo.toml
new file mode 100644
index 0000000000..4164b7b932
--- /dev/null
+++ b/third_party/rust/flagset/Cargo.toml
@@ -0,0 +1,34 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "flagset"
+version = "0.4.3"
+authors = ["Nathaniel McCallum <nathaniel@profian.com>"]
+description = "Data types and a macro for generating enumeration-based bit flags"
+homepage = "https://github.com/enarx/flagset"
+documentation = "https://docs.rs/flagset"
+readme = "README.md"
+keywords = ["flags", "bitflags", "enum", "enumflags"]
+license = "Apache-2.0"
+repository = "https://github.com/enarx/flagset"
+[package.metadata.docs.rs]
+all-features = true
+[dependencies.serde]
+version = "1.0"
+features = ["serde_derive"]
+optional = true
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.serde_repr]
+version = "0.1"