summaryrefslogtreecommitdiffstats
path: root/third_party/rust/futures-cpupool/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/futures-cpupool/Cargo.toml')
-rw-r--r--third_party/rust/futures-cpupool/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/third_party/rust/futures-cpupool/Cargo.toml b/third_party/rust/futures-cpupool/Cargo.toml
new file mode 100644
index 0000000000..4bfc90332d
--- /dev/null
+++ b/third_party/rust/futures-cpupool/Cargo.toml
@@ -0,0 +1,32 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "futures-cpupool"
+version = "0.1.8"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+description = "An implementation of thread pools which hand out futures to the results of the\ncomputation on the threads themselves.\n"
+homepage = "https://github.com/alexcrichton/futures-rs"
+documentation = "https://docs.rs/futures-cpupool"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/alexcrichton/futures-rs"
+[dependencies.futures]
+version = "0.1"
+features = ["use_std"]
+default-features = false
+
+[dependencies.num_cpus]
+version = "1.0"
+
+[features]
+default = ["with-deprecated"]
+with-deprecated = ["futures/with-deprecated"]