summaryrefslogtreecommitdiffstats
path: root/third_party/rust/http/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/http/Cargo.toml')
-rw-r--r--third_party/rust/http/Cargo.toml88
1 files changed, 88 insertions, 0 deletions
diff --git a/third_party/rust/http/Cargo.toml b/third_party/rust/http/Cargo.toml
new file mode 100644
index 0000000000..9b8e546141
--- /dev/null
+++ b/third_party/rust/http/Cargo.toml
@@ -0,0 +1,88 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.49.0"
+name = "http"
+version = "0.2.8"
+authors = [
+ "Alex Crichton <alex@alexcrichton.com>",
+ "Carl Lerche <me@carllerche.com>",
+ "Sean McArthur <sean@seanmonstar.com>",
+]
+description = """
+A set of types for representing HTTP requests and responses.
+"""
+documentation = "https://docs.rs/http"
+readme = "README.md"
+keywords = ["http"]
+categories = ["web-programming"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/hyperium/http"
+
+[[bench]]
+name = "header_map"
+path = "benches/header_map/mod.rs"
+
+[[bench]]
+name = "header_name"
+path = "benches/header_name.rs"
+
+[[bench]]
+name = "header_name2"
+path = "benches/header_name2.rs"
+harness = false
+
+[[bench]]
+name = "header_value"
+path = "benches/header_value.rs"
+
+[[bench]]
+name = "method"
+path = "benches/method.rs"
+
+[[bench]]
+name = "uri"
+path = "benches/uri.rs"
+
+[dependencies.bytes]
+version = "1"
+
+[dependencies.fnv]
+version = "1.0.5"
+
+[dependencies.itoa]
+version = "1"
+
+[dev-dependencies.criterion]
+version = "0.3.2"
+
+[dev-dependencies.doc-comment]
+version = "0.3"
+
+[dev-dependencies.indexmap]
+version = "1.0"
+
+[dev-dependencies.quickcheck]
+version = "0.9.0"
+
+[dev-dependencies.rand]
+version = "0.7.0"
+
+[dev-dependencies.seahash]
+version = "3.0.5"
+
+[dev-dependencies.serde]
+version = "1.0"
+
+[dev-dependencies.serde_json]
+version = "1.0"