summaryrefslogtreecommitdiffstats
path: root/third_party/rust/jobserver/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/jobserver/Cargo.toml')
-rw-r--r--third_party/rust/jobserver/Cargo.toml65
1 files changed, 65 insertions, 0 deletions
diff --git a/third_party/rust/jobserver/Cargo.toml b/third_party/rust/jobserver/Cargo.toml
new file mode 100644
index 0000000000..c1d0481e97
--- /dev/null
+++ b/third_party/rust/jobserver/Cargo.toml
@@ -0,0 +1,65 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "jobserver"
+version = "0.1.25"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+description = """
+An implementation of the GNU make jobserver for Rust
+"""
+homepage = "https://github.com/alexcrichton/jobserver-rs"
+documentation = "https://docs.rs/jobserver"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/alexcrichton/jobserver-rs"
+
+[[test]]
+name = "client"
+path = "tests/client.rs"
+harness = false
+
+[[test]]
+name = "server"
+path = "tests/server.rs"
+
+[[test]]
+name = "client-of-myself"
+path = "tests/client-of-myself.rs"
+harness = false
+
+[[test]]
+name = "make-as-a-client"
+path = "tests/make-as-a-client.rs"
+harness = false
+
+[[test]]
+name = "helper"
+path = "tests/helper.rs"
+
+[dev-dependencies.futures]
+version = "0.1"
+
+[dev-dependencies.num_cpus]
+version = "1.0"
+
+[dev-dependencies.tempfile]
+version = "3"
+
+[dev-dependencies.tokio-core]
+version = "0.1"
+
+[dev-dependencies.tokio-process]
+version = "0.2"
+
+[target."cfg(unix)".dependencies.libc]
+version = "0.2.50"