summaryrefslogtreecommitdiffstats
path: root/third_party/rust/mp4parse/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/mp4parse/Cargo.toml')
-rw-r--r--third_party/rust/mp4parse/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/third_party/rust/mp4parse/Cargo.toml b/third_party/rust/mp4parse/Cargo.toml
new file mode 100644
index 0000000000..161043254e
--- /dev/null
+++ b/third_party/rust/mp4parse/Cargo.toml
@@ -0,0 +1,55 @@
+[package]
+name = "mp4parse"
+version = "0.13.0"
+authors = [
+ "Ralph Giles <giles@mozilla.com>",
+ "Matthew Gregan <kinetik@flim.org>",
+ "Alfredo Yang <ayang@mozilla.com>",
+ "Jon Bauman <jbauman@mozilla.com>",
+ "Bryce Seager van Dyk <bvandyk@mozilla.com>",
+]
+
+description = "Parser for ISO base media file format (mp4)"
+documentation = "https://docs.rs/mp4parse/"
+license = "MPL-2.0"
+categories = ["multimedia::video"]
+
+repository = "https://github.com/mozilla/mp4parse-rust"
+
+# Avoid complaints about trying to package test files.
+exclude = [
+ "*.mp4",
+ "av1-avif/*"
+]
+
+[badges]
+travis-ci = { repository = "https://github.com/mozilla/mp4parse-rust" }
+
+[dependencies]
+byteorder = "1.2.1"
+bitreader = { version = "0.3.2" }
+env_logger = "0.8"
+fallible_collections = { version = "0.4", features = ["std_io"] }
+num-traits = "0.2.14"
+log = "0.4"
+static_assertions = "1.1.0"
+
+[dev-dependencies]
+test-assembler = "0.1.2"
+walkdir = "2.3.1"
+criterion = "0.3"
+
+[features]
+missing-pixi-permitted = []
+3gpp = []
+meta-xml = []
+unstable-api = []
+mp4v = []
+
+[[bench]]
+name = "avif_benchmark"
+harness = false
+
+# See https://bheisler.github.io/criterion.rs/book/faq.html#cargo-bench-gives-unrecognized-option-errors-for-valid-command-line-options
+[lib]
+bench = false