summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-crypto/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/neqo-crypto/Cargo.toml')
-rw-r--r--third_party/rust/neqo-crypto/Cargo.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/third_party/rust/neqo-crypto/Cargo.toml b/third_party/rust/neqo-crypto/Cargo.toml
new file mode 100644
index 0000000000..6de1db239a
--- /dev/null
+++ b/third_party/rust/neqo-crypto/Cargo.toml
@@ -0,0 +1,28 @@
+[package]
+name = "neqo-crypto"
+version = "0.6.3"
+authors = ["Martin Thomson <mt@lowentropy.net>"]
+edition = "2018"
+rust-version = "1.57.0"
+build = "build.rs"
+license = "MIT/Apache-2.0"
+
+[dependencies]
+neqo-common = { path = "../neqo-common" }
+log = {version = "0.4.0", default-features = false}
+
+[build-dependencies]
+bindgen = {version = "0.63", default-features = false, features= ["runtime"]}
+serde = "1.0"
+serde_derive = "1.0"
+toml = "0.5"
+mozbuild = {version = "0.1", optional = true}
+
+[dev-dependencies]
+test-fixture = { path = "../test-fixture" }
+
+[features]
+default = ["deny-warnings"]
+deny-warnings = []
+gecko = ["mozbuild"]
+fuzzing = []