summaryrefslogtreecommitdiffstats
path: root/third_party/rust/serial_test/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/serial_test/Cargo.toml')
-rw-r--r--third_party/rust/serial_test/Cargo.toml46
1 files changed, 46 insertions, 0 deletions
diff --git a/third_party/rust/serial_test/Cargo.toml b/third_party/rust/serial_test/Cargo.toml
new file mode 100644
index 0000000000..1f46e3cc66
--- /dev/null
+++ b/third_party/rust/serial_test/Cargo.toml
@@ -0,0 +1,46 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "serial_test"
+version = "0.6.0"
+authors = ["Tom Parker-Shemilt <palfrey@tevp.net>"]
+description = "Allows for the creation of serialised Rust tests"
+readme = "README.md"
+keywords = ["sequential"]
+categories = ["development-tools::testing"]
+license = "MIT"
+repository = "https://github.com/palfrey/serial_test/"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+[dependencies.document-features]
+version = "0.2"
+optional = true
+
+[dependencies.fslock]
+version = "0.2"
+optional = true
+
+[dependencies.lazy_static]
+version = "1.2"
+
+[dependencies.parking_lot]
+version = ">= 0.10, < 0.12"
+
+[dependencies.serial_test_derive]
+version = "~0.6.0"
+
+[features]
+default = []
+docsrs = ["document-features"]
+file_locks = ["fslock"]