summaryrefslogtreecommitdiffstats
path: root/third_party/rust/sync-guid/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/sync-guid/Cargo.toml')
-rw-r--r--third_party/rust/sync-guid/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/third_party/rust/sync-guid/Cargo.toml b/third_party/rust/sync-guid/Cargo.toml
new file mode 100644
index 0000000000..011d1f9b0f
--- /dev/null
+++ b/third_party/rust/sync-guid/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "sync-guid"
+version = "0.1.0"
+authors = ["Thom Chiovoloni <tchiovoloni@mozilla.com>"]
+license = "MPL-2.0"
+edition = "2021"
+
+[dependencies]
+rusqlite = { version = "0.28.0", optional = true, features = ["bundled"] }
+serde = { version = "1", optional = true }
+rand = { version = "0.8", optional = true }
+base64 = { version = "0.13", optional = true }
+
+[features]
+random = ["rand", "base64"]
+rusqlite_support = ["rusqlite"]
+serde_support = ["serde"]
+# By default we support serde, but not rusqlite.
+default = ["serde_support"]
+
+[dev-dependencies]
+serde_test = "1"