summaryrefslogtreecommitdiffstats
path: root/third_party/rust/webext-storage/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/webext-storage/Cargo.toml40
1 files changed, 40 insertions, 0 deletions
diff --git a/third_party/rust/webext-storage/Cargo.toml b/third_party/rust/webext-storage/Cargo.toml
new file mode 100644
index 0000000000..c09c51c983
--- /dev/null
+++ b/third_party/rust/webext-storage/Cargo.toml
@@ -0,0 +1,40 @@
+[package]
+name = "webext-storage"
+edition = "2021"
+version = "0.1.0"
+authors = ["sync-team@mozilla.com"]
+license = "MPL-2.0"
+
+[features]
+default = []
+
+[dependencies]
+error-support = { path = "../support/error" }
+thiserror = "1.0"
+ffi-support = "0.4"
+interrupt-support = { path = "../support/interrupt" }
+lazy_static = "1.4"
+log = "0.4"
+serde = "1"
+serde_json = "1"
+serde_derive = "1"
+sql-support = { path = "../support/sql" }
+sync15 = {path = "../../components/sync15", features=["sync-engine"]}
+sync-guid = { path = "../support/guid", features = ["rusqlite_support", "random"] }
+url = { version = "2.1", features = ["serde"] }
+
+[dependencies.rusqlite]
+version = "0.28.0"
+features = ["functions", "bundled", "serde_json", "unlock_notify", "column_decltype"]
+
+[dev-dependencies]
+env_logger = { version = "0.7", default-features = false }
+prettytable-rs = "0.8"
+tempfile = "3"
+# A *direct* dep on the -sys crate is required for our build.rs
+# to see the DEP_SQLITE3_LINK_TARGET env var that cargo sets
+# on its behalf.
+libsqlite3-sys = "0.25.2"
+
+[build-dependencies]
+nss_build_common = { path = "../support/rc_crypto/nss/nss_build_common" }