summaryrefslogtreecommitdiffstats
path: root/data/autostart
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:43:08 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:43:08 +0000
commitd524c8e88f558b9f2aebff39b6fbe77eab51e081 (patch)
tree399d1caf80df6656549115df912f6af2f7369308 /data/autostart
parentInitial commit. (diff)
downloadgdm3-d524c8e88f558b9f2aebff39b6fbe77eab51e081.tar.xz
gdm3-d524c8e88f558b9f2aebff39b6fbe77eab51e081.zip
Adding upstream version 43.0.upstream/43.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'data/autostart')
-rw-r--r--data/autostart/meson.build12
-rw-r--r--data/autostart/orca-autostart.desktop7
2 files changed, 19 insertions, 0 deletions
diff --git a/data/autostart/meson.build b/data/autostart/meson.build
new file mode 100644
index 0000000..348a6c6
--- /dev/null
+++ b/data/autostart/meson.build
@@ -0,0 +1,12 @@
+autostart_files_conf = {
+ 'LIBEXECDIR': gdm_prefix / get_option('libexecdir'),
+}
+
+foreach autostart_file : [ 'orca-autostart.desktop' ]
+ configure_file(
+ input: autostart_file,
+ output: autostart_file,
+ configuration: autostart_files_conf,
+ install_dir: get_option('datadir') / 'gdm' / 'greeter' / 'autostart',
+ )
+endforeach
diff --git a/data/autostart/orca-autostart.desktop b/data/autostart/orca-autostart.desktop
new file mode 100644
index 0000000..944cfd7
--- /dev/null
+++ b/data/autostart/orca-autostart.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Orca screen reader
+Exec=orca --disable main-window,splash-window --enable speech,braille
+NoDisplay=true
+AutostartCondition=GSettings org.gnome.desktop.a11y.applications screen-reader-enabled
+X-GNOME-AutoRestart=true