summaryrefslogtreecommitdiffstats
path: root/debian/changelog.upstream.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:47:55 +0000
commitf04f772d4c2791a1bc0e36fe8df2dc8d62ea8378 (patch)
tree6601becfb9eccb5e3361f1f802e96ea7839bfca8 /debian/changelog.upstream.sh
parentAdding upstream version 1:2.39.2. (diff)
downloadgit-f04f772d4c2791a1bc0e36fe8df2dc8d62ea8378.tar.xz
git-f04f772d4c2791a1bc0e36fe8df2dc8d62ea8378.zip
Adding debian version 1:2.39.2-1.1.debian/1%2.39.2-1.1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/changelog.upstream.sh')
-rwxr-xr-xdebian/changelog.upstream.sh16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/changelog.upstream.sh b/debian/changelog.upstream.sh
new file mode 100755
index 0000000..3441546
--- /dev/null
+++ b/debian/changelog.upstream.sh
@@ -0,0 +1,16 @@
+#!/bin/sh
+set -e
+: >debian/changelog.upstream
+exec <debian/versions.upstream
+read old
+while read new; do
+ exec >debian/changelog.upstream."$new"
+ echo "Version $new; changes since $old:"
+ echo "Version $new; changes since $old:" |tr '[:print:]' -
+ echo
+ git shortlog --no-merges "$old".."$new"
+ echo
+ cat debian/changelog.upstream
+ mv debian/changelog.upstream."$new" debian/changelog.upstream
+ old="$new"
+done