summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules42
1 files changed, 42 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..07f0478
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,42 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_CPPFLAGS_MAINT_APPEND = -DSSHD_SERVICE=\"ssh.service\"
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs
+
+# Not in Ubuntu main yet https://launchpad.net/bugs/1892456
+ifeq ($(shell dpkg-vendor --is Ubuntu && echo yes),yes)
+DISTRIBUTOR_LOGO := /usr/share/pixmaps/ubuntu-logo-text.png
+DISTRIBUTOR_LOGO_DARK := /usr/share/pixmaps/ubuntu-logo-text-dark.png
+MALCONTENT := -Dmalcontent=false
+else
+DISTRIBUTOR_LOGO := /usr/share/icons/vendor/scalable/emblems/emblem-vendor.svg
+DISTRIBUTOR_LOGO_DARK := /usr/share/icons/vendor/scalable/emblems/emblem-vendor.svg
+ifneq (,$(filter $(DEB_HOST_ARCH), amd64 arm64 armel armhf i386 mips mipsel mips64el ppc64el s390x hppa powerpc powerpcspe ppc64))
+MALCONTENT := -Dmalcontent=true
+else
+MALCONTENT := -Dmalcontent=false
+endif
+endif
+
+ifeq ($(DEB_HOST_ARCH_OS),linux)
+SNAP := -Dsnap=true
+else
+SNAP := -Dsnap=false
+endif
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ -Dprivileged_group=sudo \
+ -Ddocumentation=true \
+ -Ddistributor_logo=$(DISTRIBUTOR_LOGO) \
+ -Ddark_mode_distributor_logo=$(DISTRIBUTOR_LOGO) \
+ $(MALCONTENT) \
+ $(SNAP)
+
+# Ubuntu-specific
+override_dh_translations:
+ dh_translations --domain=gnome-control-center-2.0