summaryrefslogtreecommitdiffstats
path: root/tests/keyboard/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/keyboard/meson.build')
-rw-r--r--tests/keyboard/meson.build33
1 files changed, 33 insertions, 0 deletions
diff --git a/tests/keyboard/meson.build b/tests/keyboard/meson.build
new file mode 100644
index 0000000..4b724b4
--- /dev/null
+++ b/tests/keyboard/meson.build
@@ -0,0 +1,33 @@
+test_units = [
+ 'test-keyboard-shortcuts'
+]
+
+env = [
+ 'G_MESSAGES_DEBUG=all',
+ 'BUILDDIR=' + meson.current_build_dir(),
+ 'TOP_BUILDDIR=' + meson.build_root(),
+# Disable ATK, this should not be required but it caused CI failures -- 2018-12-07
+ 'NO_AT_BRIDGE=1'
+]
+cflags = [
+ '-DTEST_SRCDIR="@0@"'.format(meson.current_source_dir())
+]
+includes = [top_inc, include_directories('../../panels/keyboard')]
+
+foreach unit: test_units
+ exe = executable(
+ unit,
+ [unit + '.c'],
+ dependencies : common_deps,
+ include_directories : includes,
+ link_with : [keyboard_panel_lib],
+ c_args : cflags
+ )
+endforeach
+
+test(
+ 'test-keyboard',
+ find_program('test-keyboard.py'),
+ env : env,
+ timeout : 60
+)