summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:19:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:19:51 +0000
commitdf7baa2644d541634825e28851c2bd8a47cd5233 (patch)
tree097c499ac161feb4345b18a4f6605e7199d6a635 /Makefile
parentInitial commit. (diff)
downloadgnome-shell-extension-impatience-df7baa2644d541634825e28851c2bd8a47cd5233.tar.xz
gnome-shell-extension-impatience-df7baa2644d541634825e28851c2bd8a47cd5233.zip
Adding upstream version 0.4.8.upstream/0.4.8upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..c921969
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,13 @@
+all: schemas zip
+
+0: phony
+ mkzero-gfxmonk -p impatience -p xdg gnome-shell-impatience.xml
+
+schemas: phony
+ cd impatience/schemas && glib-compile-schemas .
+
+zip: phony
+ rm -f impatience@gfxmonk.net.zip
+ cd impatience && zip -r ../impatience@gfxmonk.net.zip *
+
+.PHONY: phony