summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:54:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:54:44 +0000
commitc16cb1dcba60b0811b3c46aa4734b998a18fc8dc (patch)
tree43c388f09756344e3f0243122526bcfd61421ee9 /debian/rules
parentAdding upstream version 43.9. (diff)
downloadgnome-shell-6a839e44a23127b514fcc3bfa8d9c3a9bcbf3937.tar.xz
gnome-shell-6a839e44a23127b514fcc3bfa8d9c3a9bcbf3937.zip
Adding debian version 43.9-0+deb12u1.debian/43.9-0+deb12u1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules40
1 files changed, 40 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..426dfa7
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,40 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs
+
+%:
+ dh $@ --with bash_completion
+
+CONFFLAGS =
+
+ifeq ($(DEB_HOST_ARCH_OS),linux)
+CONFFLAGS += \
+ -Dnetworkmanager=true \
+ -Dsoup2=false \
+ -Dsystemd=true
+endif
+
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+CONFFLAGS += -Dtests=true
+else
+CONFFLAGS += -Dtests=false
+endif
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --libdir=/usr/lib \
+ -Dextensions-tool:bash_completion=enabled \
+ $(CONFFLAGS)
+
+override_dh_makeshlibs:
+ dh_makeshlibs -X/usr/lib/gnome-shell/
+
+override_dh_shlibdeps:
+ # gnome-shell uses mutters private mutter-clutter-1.0.so etc.
+ dh_shlibdeps -l"usr/lib/$(DEB_HOST_MULTIARCH)/mutter"
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ dbus-run-session xvfb-run -a dh_auto_test
+endif