diff options
author | Daniel Baumann <daniel.baumann@progress-linux.org> | 2023-02-11 09:41:03 +0000 |
---|---|---|
committer | Daniel Baumann <daniel.baumann@progress-linux.org> | 2023-02-11 09:41:03 +0000 |
commit | 0335fbcd287f217c6b9d553dcfb840e6c794ef01 (patch) | |
tree | d66af584e20e084415babb02d40efe99ced18916 | |
parent | Releasing progress-linux version 43.3-1progress7u1. (diff) | |
download | gnome-software-0335fbcd287f217c6b9d553dcfb840e6c794ef01.tar.xz gnome-software-0335fbcd287f217c6b9d553dcfb840e6c794ef01.zip |
Merging upstream version 43.4.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r-- | NEWS | 8 | ||||
-rw-r--r-- | data/metainfo/org.gnome.Software.metainfo.xml.in | 9 | ||||
-rw-r--r-- | lib/gs-appstream.c | 8 | ||||
-rw-r--r-- | lib/gs-plugin.c | 2 | ||||
-rw-r--r-- | meson.build | 2 |
5 files changed, 26 insertions, 3 deletions
@@ -1,3 +1,11 @@ +Version 43.4 +~~~~~~~~~~~~ +Released: 2023-02-10 + +This is a stable release with the following changes: + * Stop cancelled search in appstream data early + * Lookup for appstream-provided icons in more directories + Version 43.3 ~~~~~~~~~~~~ Released: 2023-01-06 diff --git a/data/metainfo/org.gnome.Software.metainfo.xml.in b/data/metainfo/org.gnome.Software.metainfo.xml.in index 7f2238b..27b65fc 100644 --- a/data/metainfo/org.gnome.Software.metainfo.xml.in +++ b/data/metainfo/org.gnome.Software.metainfo.xml.in @@ -66,6 +66,15 @@ Validate with `appstreamcli validate *.metainfo.xml` --> <releases> + <release date="2023-02-10" version="43.4" type="stable"> + <description> + <p>This is a stable release with the following changes:</p> + <ul> + <li>Stop cancelled search in appstream data early</li> + <li>Lookup for appstream-provided icons in more directories</li> + </ul> + </description> + </release> <release date="2023-01-06" version="43.3" type="stable"> <description> <p>This is a stable release with the following changes:</p> diff --git a/lib/gs-appstream.c b/lib/gs-appstream.c index 193a3db..fa94a6e 100644 --- a/lib/gs-appstream.c +++ b/lib/gs-appstream.c @@ -203,7 +203,10 @@ gs_appstream_build_icon_prefix (XbNode *component) /* check format */ path = g_strsplit (tmp, "/", -1); npath = g_strv_length (path); - if (npath < 3 || !(g_strcmp0 (path[npath-2], "xmls") == 0 || g_strcmp0 (path[npath-2], "yaml") == 0)) + if (npath < 3 || + !(g_strcmp0 (path[npath-2], "xmls") == 0 || + g_strcmp0 (path[npath-2], "yaml") == 0 || + g_strcmp0 (path[npath-2], "xml") == 0)) return NULL; /* fix the new path */ @@ -1530,6 +1533,9 @@ gs_appstream_do_search (GsPlugin *plugin, } } } + + if (g_cancellable_set_error_if_cancelled (cancellable, error)) + return FALSE; } g_debug ("search took %fms", g_timer_elapsed (timer, NULL) * 1000); return TRUE; diff --git a/lib/gs-plugin.c b/lib/gs-plugin.c index da920a4..51e0f7e 100644 --- a/lib/gs-plugin.c +++ b/lib/gs-plugin.c @@ -1092,7 +1092,7 @@ gs_plugin_reload_cb (gpointer user_data) void gs_plugin_reload (GsPlugin *plugin) { - g_debug ("emitting ::reload in idle"); + g_debug ("emitting %s::reload in idle", gs_plugin_get_name (plugin)); g_idle_add_full (G_PRIORITY_DEFAULT_IDLE, gs_plugin_reload_cb, weak_ref_new (plugin), (GDestroyNotify) weak_ref_free); } diff --git a/meson.build b/meson.build index 296e6ea..77e3eab 100644 --- a/meson.build +++ b/meson.build @@ -1,5 +1,5 @@ project('gnome-software', 'c', - version : '43.3', + version : '43.4', license : 'GPL-2.0+', default_options : ['warning_level=1', 'c_std=c11'], meson_version : '>=0.58.0' |