summaryrefslogtreecommitdiffstats
path: root/data/icons/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:02:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:02:09 +0000
commit0f7ab3dc0ed5cfddfc3002992f0525756b6b670e (patch)
tree4f520e757f99f136e01abe1dd2e0d1fad5c3cd11 /data/icons/meson.build
parentInitial commit. (diff)
downloadgnome-terminal-0f7ab3dc0ed5cfddfc3002992f0525756b6b670e.tar.xz
gnome-terminal-0f7ab3dc0ed5cfddfc3002992f0525756b6b670e.zip
Adding upstream version 3.46.8.upstream/3.46.8upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'data/icons/meson.build')
-rw-r--r--data/icons/meson.build48
1 files changed, 48 insertions, 0 deletions
diff --git a/data/icons/meson.build b/data/icons/meson.build
new file mode 100644
index 0000000..ccb44fc
--- /dev/null
+++ b/data/icons/meson.build
@@ -0,0 +1,48 @@
+# Copyright © 2019, 2020, 2021 Christian Persch
+#
+# This programme is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or (at your
+# option) any later version.
+#
+# This programme is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+# See the GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this programme. If not, see <https://www.gnu.org/licenses/>.
+
+public_icons_themes = [
+ 'hicolor',
+]
+
+public_icons_sources = [
+ 'hicolor_apps_scalable_org.gnome.Terminal.svg',
+ 'hicolor_apps_scalable_org.gnome.Terminal.Preferences.svg',
+ 'hicolor_apps_symbolic_org.gnome.Terminal-symbolic.svg',
+ 'hicolor_apps_symbolic_org.gnome.Terminal.Preferences-symbolic.svg',
+]
+
+public_icons_renames = []
+
+foreach icon : public_icons_sources
+ components = icon.split('_')
+ public_icons_renames += components[0] / components[2] / components[1] / components[3]
+endforeach
+
+icondir = gt_datadir / 'icons'
+pkgicondir = gt_pkgdatadir / 'icons'
+
+install_data(
+ sources: public_icons_sources,
+ rename: public_icons_renames,
+ install_dir: icondir,
+)
+
+foreach theme : public_icons_themes
+ meson.add_install_script(
+ 'meson_updateiconcache.py',
+ icondir / theme,
+ )
+endforeach