summaryrefslogtreecommitdiffstats
path: root/debian/patches/skip-test-glyph-big-endian.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:24:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:24:52 +0000
commit57759c415099a81a2d25ce2de6fecadb07513f67 (patch)
tree3f501adeb6375a01d429fac6f27a6ecee07b3541 /debian/patches/skip-test-glyph-big-endian.patch
parentAdding upstream version 1.2.2. (diff)
downloadinkscape-57759c415099a81a2d25ce2de6fecadb07513f67.tar.xz
inkscape-57759c415099a81a2d25ce2de6fecadb07513f67.zip
Adding debian version 1.2.2-2.debian/1.2.2-2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/skip-test-glyph-big-endian.patch')
-rw-r--r--debian/patches/skip-test-glyph-big-endian.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/debian/patches/skip-test-glyph-big-endian.patch b/debian/patches/skip-test-glyph-big-endian.patch
new file mode 100644
index 0000000..f01fb65
--- /dev/null
+++ b/debian/patches/skip-test-glyph-big-endian.patch
@@ -0,0 +1,29 @@
+Description: skip this test that fail on s390x, ppc64, sparc64
+ Here the failure is real, but let's just ignore it since it only concerns BE
+Bug: https://gitlab.com/inkscape/inkscape/-/issues/4032
+Author: Mattia Rizzolo <mattia@debian.org>
+Forwarded: not-needed
+Last-Update: 2023-01-10
+
+--- a/testfiles/rendering_tests/CMakeLists.txt
++++ b/testfiles/rendering_tests/CMakeLists.txt
+@@ -2,7 +2,11 @@
+
+ # Tests to run for 64-bit builds only. These fail in 32-bit builds (possibly due to rounding issues)
+ # TODO: Figure out actual cause and see if we can fix it
++# They also started failing in big-endian, so run them only for little-endian.
++include (TestBigEndian)
++TEST_BIG_ENDIAN(IS_BIG_ENDIAN)
+ if(${CMAKE_SIZEOF_VOID_P} EQUAL 8)
++if(NOT IS_BIG_ENDIAN)
+ set(RENDERING_TESTS_64bit
+ # test-rtl-vertical
+
+@@ -10,6 +14,7 @@
+ text-gzipped-svg-glyph
+ )
+ endif()
++endif()
+
+ #add your test here (do not put the .svg extension)
+ set(RENDERING_TESTS