summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/adaptagrams/libvpsc/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:24:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:24:48 +0000
commitcca66b9ec4e494c1d919bff0f71a820d8afab1fa (patch)
tree146f39ded1c938019e1ed42d30923c2ac9e86789 /src/3rdparty/adaptagrams/libvpsc/Makefile.am
parentInitial commit. (diff)
downloadinkscape-cca66b9ec4e494c1d919bff0f71a820d8afab1fa.tar.xz
inkscape-cca66b9ec4e494c1d919bff0f71a820d8afab1fa.zip
Adding upstream version 1.2.2.upstream/1.2.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--src/3rdparty/adaptagrams/libvpsc/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/3rdparty/adaptagrams/libvpsc/Makefile.am b/src/3rdparty/adaptagrams/libvpsc/Makefile.am
new file mode 100644
index 0000000..12e779a
--- /dev/null
+++ b/src/3rdparty/adaptagrams/libvpsc/Makefile.am
@@ -0,0 +1,42 @@
+EXTRA_DIST=libvpsc.pc.in
+lib_LTLIBRARIES = libvpsc.la
+libvpsc_la_CPPFLAGS = -I$(top_srcdir) -I$(includedir)/libvpsc -fPIC
+libvpsc_la_LDFLAGS = -no-undefined
+
+#DEFS=-DLIBVPSC_LOGGING
+
+
+libvpsc_la_SOURCES = block.cpp\
+ blocks.cpp\
+ constraint.cpp\
+ rectangle.cpp\
+ solve_VPSC.cpp\
+ variable.cpp\
+ cbuffer.cpp\
+ isnan.h\
+ block.h\
+ blocks.h\
+ constraint.h\
+ rectangle.h\
+ pairingheap.h\
+ solve_VPSC.h\
+ variable.h\
+ cbuffer.h\
+ linesegment.h\
+ assertions.h
+
+libvpscincludedir = $(includedir)/libvpsc
+
+libvpscinclude_HEADERS = solve_VPSC.h \
+ block.h\
+ constraint.h\
+ exceptions.h\
+ rectangle.h\
+ variable.h \
+ assertions.h
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libvpsc.pc
+
+SUBDIRS = . tests
+