summaryrefslogtreecommitdiffstats
path: root/src/object/filters/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:24:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:24:48 +0000
commitcca66b9ec4e494c1d919bff0f71a820d8afab1fa (patch)
tree146f39ded1c938019e1ed42d30923c2ac9e86789 /src/object/filters/CMakeLists.txt
parentInitial commit. (diff)
downloadinkscape-upstream/1.2.2.tar.xz
inkscape-upstream/1.2.2.zip
Adding upstream version 1.2.2.upstream/1.2.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--src/object/filters/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/src/object/filters/CMakeLists.txt b/src/object/filters/CMakeLists.txt
new file mode 100644
index 0000000..14ea76b
--- /dev/null
+++ b/src/object/filters/CMakeLists.txt
@@ -0,0 +1,54 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+set(filters_SRC
+ sp-filter-primitive.cpp
+ blend.cpp
+ colormatrix.cpp
+ componenttransfer-funcnode.cpp
+ componenttransfer.cpp
+ composite.cpp
+ convolvematrix.cpp
+ diffuselighting.cpp
+ displacementmap.cpp
+ distantlight.cpp
+ flood.cpp
+ gaussian-blur.cpp
+ image.cpp
+ merge.cpp
+ mergenode.cpp
+ morphology.cpp
+ offset.cpp
+ pointlight.cpp
+ specularlighting.cpp
+ spotlight.cpp
+ tile.cpp
+ turbulence.cpp
+
+
+ # -------
+ # Headers
+ sp-filter-primitive.h
+ blend.h
+ colormatrix.h
+ componenttransfer-funcnode.h
+ componenttransfer.h
+ composite.h
+ convolvematrix.h
+ diffuselighting.h
+ displacementmap.h
+ distantlight.h
+ flood.h
+ gaussian-blur.h
+ image.h
+ merge.h
+ mergenode.h
+ morphology.h
+ offset.h
+ pointlight.h
+ specularlighting.h
+ spotlight.h
+ tile.h
+ turbulence.h
+)
+
+add_inkscape_source("${filters_SRC}")