summaryrefslogtreecommitdiffstats
path: root/share/extensions/other/clipart/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'share/extensions/other/clipart/pyproject.toml')
-rw-r--r--share/extensions/other/clipart/pyproject.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/share/extensions/other/clipart/pyproject.toml b/share/extensions/other/clipart/pyproject.toml
new file mode 100644
index 0000000..fd36dc6
--- /dev/null
+++ b/share/extensions/other/clipart/pyproject.toml
@@ -0,0 +1,19 @@
+[tool.poetry]
+name = "import-web-image"
+version = "1.0.0"
+description = "A GTK3 based web image importer."
+authors = ["Martin Owens <doctormo@geek-2.com>"]
+maintainers = ["Martin Owens <doctormo@geek-2.com>"]
+license = "GPL-3.0-or-later"
+
+# The dependencies below are NOT used for packaging, they are abstract.
+# They are merely for packagers' convenience and are used in CI for extensions.
+[tool.poetry.dependencies]
+python = ">=3.7"
+appdirs = "1.4.4"
+requests = "*"
+CacheControl = {extras = ["filecache"], version = "*"}
+
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"