summaryrefslogtreecommitdiffstats
path: root/share/icons/Tango/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--share/icons/Tango/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/share/icons/Tango/CMakeLists.txt b/share/icons/Tango/CMakeLists.txt
new file mode 100644
index 0000000..84beba5
--- /dev/null
+++ b/share/icons/Tango/CMakeLists.txt
@@ -0,0 +1,16 @@
+set(THEME Tango)
+install(FILES "index.theme" DESTINATION ${INKSCAPE_SHARE_INSTALL}/icons/${THEME} COMPONENT themes)
+
+set(PIXMAP_SIZES "scalable")
+set(CONTENT "actions")
+
+foreach(pixmap_size ${PIXMAP_SIZES})
+ foreach(content ${CONTENT})
+ FILE(GLOB PIXMAP_FILES ${CMAKE_CURRENT_SOURCE_DIR}/${pixmap_size}/${content}/*.png ${CMAKE_CURRENT_SOURCE_DIR}/${pixmap_size}/${content}/*.svg)
+ install(FILES ${PIXMAP_FILES} DESTINATION ${INKSCAPE_SHARE_INSTALL}/icons/${THEME}/${pixmap_size}/${content} COMPONENT themes)
+ endforeach(content)
+endforeach(pixmap_size)
+
+if(WIN32)
+ install(CODE "execute_process(COMMAND gtk-update-icon-cache \${CMAKE_INSTALL_PREFIX}/${INKSCAPE_SHARE_INSTALL}/icons/${THEME})")
+endif()