summaryrefslogtreecommitdiffstats
path: root/modules/edns_keepalive/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:26:00 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:26:00 +0000
commit830407e88f9d40d954356c3754f2647f91d5c06a (patch)
treed6a0ece6feea91f3c656166dbaa884ef8a29740e /modules/edns_keepalive/meson.build
parentInitial commit. (diff)
downloadknot-resolver-830407e88f9d40d954356c3754f2647f91d5c06a.tar.xz
knot-resolver-830407e88f9d40d954356c3754f2647f91d5c06a.zip
Adding upstream version 5.6.0.upstream/5.6.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'modules/edns_keepalive/meson.build')
-rw-r--r--modules/edns_keepalive/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/modules/edns_keepalive/meson.build b/modules/edns_keepalive/meson.build
new file mode 100644
index 0000000..979452f
--- /dev/null
+++ b/modules/edns_keepalive/meson.build
@@ -0,0 +1,17 @@
+# C module: edns_keepalive
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+edns_keepalive_src = files([
+ 'edns_keepalive.c',
+])
+c_src_lint += edns_keepalive_src
+
+edns_keepalive_mod = shared_module(
+ 'edns_keepalive',
+ edns_keepalive_src,
+ dependencies: libknot,
+ include_directories: mod_inc_dir,
+ name_prefix: '',
+ install: true,
+ install_dir: modules_dir,
+)