summaryrefslogtreecommitdiffstats
path: root/configmgr/Library_configmgr.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /configmgr/Library_configmgr.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'configmgr/Library_configmgr.mk')
-rw-r--r--configmgr/Library_configmgr.mk67
1 files changed, 67 insertions, 0 deletions
diff --git a/configmgr/Library_configmgr.mk b/configmgr/Library_configmgr.mk
new file mode 100644
index 000000000..11bba5f0f
--- /dev/null
+++ b/configmgr/Library_configmgr.mk
@@ -0,0 +1,67 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,configmgr))
+
+$(eval $(call gb_Library_set_precompiled_header,configmgr,configmgr/inc/pch/precompiled_configmgr))
+
+$(eval $(call gb_Library_add_exception_objects,configmgr, \
+ configmgr/source/access \
+ configmgr/source/broadcaster \
+ configmgr/source/childaccess \
+ configmgr/source/components \
+ configmgr/source/configurationprovider \
+ configmgr/source/configurationregistry \
+ configmgr/source/data \
+ configmgr/source/defaultprovider \
+ configmgr/source/groupnode \
+ configmgr/source/localizedpropertynode \
+ configmgr/source/localizedvaluenode \
+ configmgr/source/lock \
+ configmgr/source/modifications \
+ configmgr/source/node \
+ configmgr/source/nodemap \
+ configmgr/source/parsemanager \
+ configmgr/source/partial \
+ configmgr/source/propertynode \
+ configmgr/source/readonlyaccess \
+ configmgr/source/readwriteaccess \
+ configmgr/source/rootaccess \
+ configmgr/source/rootnode \
+ configmgr/source/setnode \
+ configmgr/source/type \
+ configmgr/source/update \
+ configmgr/source/valueparser \
+ configmgr/source/writemodfile \
+ configmgr/source/xcdparser \
+ configmgr/source/xcsparser \
+ configmgr/source/xcuparser \
+ configmgr/source/xmldata \
+ $(if $(ENABLE_DCONF),configmgr/source/dconf) \
+ $(if $(filter $(OS),WNT),configmgr/source/winreg) \
+))
+
+$(eval $(call gb_Library_use_externals,configmgr, \
+ boost_headers \
+ dconf \
+))
+
+$(eval $(call gb_Library_use_sdk_api,configmgr))
+
+$(eval $(call gb_Library_use_libraries,configmgr, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ salhelper \
+ tl \
+ xmlreader \
+ i18nlangtag \
+))
+
+$(eval $(call gb_Library_set_componentfile,configmgr,configmgr/source/configmgr,services))