summaryrefslogtreecommitdiffstats
path: root/debian/patches/debian-hardened-buildflags-CPPFLAGS.diff
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:07:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:07:31 +0000
commitedaebb65d92a48d7075c8c1f64c5ffd87054827b (patch)
tree045c941e1851cde1665bea22d97a2976b7a5bb69 /debian/patches/debian-hardened-buildflags-CPPFLAGS.diff
parentAdding upstream version 4:7.4.7. (diff)
downloadlibreoffice-edaebb65d92a48d7075c8c1f64c5ffd87054827b.tar.xz
libreoffice-edaebb65d92a48d7075c8c1f64c5ffd87054827b.zip
Adding debian version 4:7.4.7-1+deb12u1.debian/4%7.4.7-1+deb12u1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/debian-hardened-buildflags-CPPFLAGS.diff')
-rw-r--r--debian/patches/debian-hardened-buildflags-CPPFLAGS.diff37
1 files changed, 37 insertions, 0 deletions
diff --git a/debian/patches/debian-hardened-buildflags-CPPFLAGS.diff b/debian/patches/debian-hardened-buildflags-CPPFLAGS.diff
new file mode 100644
index 000000000..26061d63f
--- /dev/null
+++ b/debian/patches/debian-hardened-buildflags-CPPFLAGS.diff
@@ -0,0 +1,37 @@
+--- a/configure.ac-old 2012-03-02 21:48:47.000000000 +0000
++++ b/configure.ac 2012-03-02 21:51:29.000000000 +0000
+@@ -10225,6 +10225,11 @@ else
+ AC_SUBST(GSTREAMER_1_0_LIBS)
+ AC_SUBST(ENABLE_GSTREAMER_1_0)
+
++if test -x /usr/bin/dpkg-buildflags; then
++ HARDEN_CPPFLAGS=`dpkg-buildflags --get CPPFLAGS 2>/dev/null`
++fi
++AC_SUBST(HARDEN_CPPFLAGS)
++
+ ENABLE_OPENGL_TRANSITIONS=
+ ENABLE_OPENGL_CANVAS=
+ if test $_os = iOS -o $_os = Android -o "$ENABLE_FUZZERS" = "TRUE"; then
+--- a/config_host.mk.in-old 2012-04-06 14:17:55.164239390 +0200
++++ b/config_host.mk.in 2012-04-06 14:18:55.440239065 +0200
+@@ -76,6 +76,7 @@
+ export CPPUNIT_LIBS=$(gb_SPACE)@CPPUNIT_LIBS@
+ export CPUNAME=@CPUNAME@
+ export CDEFAULTOPT=@CDEFAULTOPT@
++export HARDEN_CPPFLAGS=@HARDEN_CPPFLAGS@
+ export CROSS_COMPILING=@CROSS_COMPILING@
+ export CURL=@CURL@
+ export CURL_CFLAGS=$(gb_SPACE)@CURL_CFLAGS@
+diff --git a/solenv/gbuild/gbuild.mk b/solenv/gbuild/gbuild.mk
+index c71cb40..f826d65 100644
+--- a/solenv/gbuild/gbuild.mk
++++ b/solenv/gbuild/gbuild.mk
+@@ -259,6 +259,8 @@ gb_GLOBALDEFS += \
+ DISABLE_DYNLOADING \
+ )
+
++gb_GLOBALDEFS += $(HARDEN_CPPFLAGS)
++
+ gb_GLOBALDEFS := $(sort $(gb_GLOBALDEFS))
+
+ # Common environment variables passed into all gb_*Test classes: