summaryrefslogtreecommitdiffstats
path: root/desktop/Executable_sdraw.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /desktop/Executable_sdraw.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'desktop/Executable_sdraw.mk')
-rw-r--r--desktop/Executable_sdraw.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/desktop/Executable_sdraw.mk b/desktop/Executable_sdraw.mk
new file mode 100644
index 000000000..164b65876
--- /dev/null
+++ b/desktop/Executable_sdraw.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,sdraw))
+
+$(eval $(call gb_Executable_set_targettype_gui,sdraw,YES))
+
+$(eval $(call gb_Executable_add_ldflags,sdraw,\
+ /ENTRY:wWinMainCRTStartup \
+))
+
+$(eval $(call gb_Executable_use_static_libraries,sdraw,\
+ winlauncher \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,sdraw,\
+ desktop/win32/source/applauncher/sdraw \
+))
+
+$(eval $(call gb_Executable_add_nativeres,sdraw,sdraw/launcher))
+
+$(eval $(call gb_Executable_add_default_nativeres,sdraw,$(PRODUCTNAME) Draw))
+
+# vim: set ts=4 sw=4 et: