summaryrefslogtreecommitdiffstats
path: root/desktop/Jar_active_java.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /desktop/Jar_active_java.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'desktop/Jar_active_java.mk')
-rw-r--r--desktop/Jar_active_java.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/desktop/Jar_active_java.mk b/desktop/Jar_active_java.mk
new file mode 100644
index 000000000..48fb7425e
--- /dev/null
+++ b/desktop/Jar_active_java.mk
@@ -0,0 +1,26 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Jar_Jar,active_java))
+
+$(eval $(call gb_Jar_add_sourcefiles,active_java, \
+ desktop/test/deployment/active/com/sun/star/comp/test/deployment/Dispatch \
+ desktop/test/deployment/active/com/sun/star/comp/test/deployment/Provider \
+ desktop/test/deployment/active/com/sun/star/comp/test/deployment/Services \
+))
+
+$(eval $(call gb_Jar_set_manifest,active_java,$(SRCDIR)/desktop/test/deployment/active/MANIFEST.MF))
+
+$(eval $(call gb_Jar_set_packageroot,active_java,com))
+
+$(eval $(call gb_Jar_use_jars,active_java, \
+ libreoffice \
+))
+
+# vim: set noet sw=4 ts=4: