summaryrefslogtreecommitdiffstats
path: root/desktop/WinResTarget_quickstart.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /desktop/WinResTarget_quickstart.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'desktop/WinResTarget_quickstart.mk')
-rw-r--r--desktop/WinResTarget_quickstart.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/desktop/WinResTarget_quickstart.mk b/desktop/WinResTarget_quickstart.mk
new file mode 100644
index 000000000..0c06f5990
--- /dev/null
+++ b/desktop/WinResTarget_quickstart.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_WinResTarget_WinResTarget,quickstart/QuickStart))
+
+$(eval $(call gb_WinResTarget_set_include,quickstart/QuickStart,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/desktop/win32/source/QuickStart \
+ -I$(SRCDIR)/sysui/desktop \
+))
+
+$(eval $(call gb_WinResTarget_add_dependencies,quickstart/QuickStart,\
+ sysui/desktop/icons/soffice.ico \
+))
+
+$(eval $(call gb_WinResTarget_set_rcfile,quickstart/QuickStart,desktop/win32/source/QuickStart/QuickStart))
+
+# vim: set ts=4 sw=4 et: