summaryrefslogtreecommitdiffstats
path: root/extensions/CustomTarget_so_activex_x64.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /extensions/CustomTarget_so_activex_x64.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extensions/CustomTarget_so_activex_x64.mk')
-rw-r--r--extensions/CustomTarget_so_activex_x64.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/extensions/CustomTarget_so_activex_x64.mk b/extensions/CustomTarget_so_activex_x64.mk
new file mode 100644
index 000000000..6b1b35d94
--- /dev/null
+++ b/extensions/CustomTarget_so_activex_x64.mk
@@ -0,0 +1,25 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,extensions/source/activex))
+
+$(call gb_CustomTarget_get_target,extensions/source/activex) : \
+ $(call gb_CustomTarget_get_workdir,extensions/source/activex)/SOActionsApproval.cxx \
+ $(call gb_CustomTarget_get_workdir,extensions/source/activex)/SOActiveX.cxx \
+ $(call gb_CustomTarget_get_workdir,extensions/source/activex)/SOComWindowPeer.cxx \
+ $(call gb_CustomTarget_get_workdir,extensions/source/activex)/SODispatchInterceptor.cxx \
+ $(call gb_CustomTarget_get_workdir,extensions/source/activex)/StdAfx2.cxx \
+ $(call gb_CustomTarget_get_workdir,extensions/source/activex)/so_activex.cxx \
+
+$(call gb_CustomTarget_get_workdir,extensions/source/activex)/% : \
+ $(SRCDIR)/extensions/source/activex/% \
+ | $(call gb_CustomTarget_get_workdir,extensions/source/activex)/.dir
+ cp $< $@
+
+# vim:set shiftwidth=4 tabstop=4 noexpandtab: